Mentor Graphics ModelSim 5.4e

Date of last revision: 04/05/2001

ModelSim is a circuit simulation tool.

Mentor Graphics ModelSim 5.4e help index:


Availability


Conflicts


Preparation

Note: If you have projects created with a version of ModelSim older than 5.4, you must regenerate your design libraries as described in the Notes section.

Mentor Graphics ModelSim 5.4e uses standard setup scripts. You must type

setup modelsim

to use this application. If you want to run this version of the software even if other versions are available, use modelsim-5.4e instead of modelsim in your setup statement.

See "helpme setup" for information on finding out what versions are available or what to do if the setup statement does not work.


Running Mentor Graphics ModelSim 5.4e

Type:

vsim


Notes

These instructions are taken directly from the ModelSim documentation.

When you upgrade between number versions (e.g., from 5.3 to 5.4), you must regenerate your design libraries. This is not true for letter versions (e.g., 5.4a to 5.4d).

You can easily regenerate your design libraries with -refresh. You must use the vcom compiler with the -refresh option to update the VHDL design units in a library, and vlog with the -refresh option to update Verilog design units. By default, the work library is updated; use -work <library> to update a different library. For example, if you have a library named mylib that contains both VHDL and Verilog design units you would use both of these commands:

vcom -work mylib -refresh
vlog -work mylib -refresh


Other Information Resources


Other Topics of Interest